Jan 16, 2012

Struggling with Azure SDK Samples –> use Microsoft.ServiceBus.dll Version 1.6! or still 1.5?

Got some issues recently with the Azure SDK samples (e.g. RelayedConnectionSample with NetTcp, MulticastSample, etc.). SecurityExceptions were thrown, etc.

Until I noticed that the samples still reference the Microsoft.ServiceBus.dll in

  • version 1.5.0.0 under c:\Program Files\Windows Azure AppFabric SDK\V1.5\Assemblies\NET4.0\ instead of the latest one
  • version 1.6.0.0 which is now installed under C:\Program Files\Windows Azure SDK\v1.6\ServiceBus\ref

So you need to

  1. change assembly references to Microsoft.ServiceBus 1.6.0.0
  2. change .config settings to 1.6.0.0 to:

    <extensions>

      <bindingExtensions>

        <add name="netEventRelayBinding" type="Microsoft.ServiceBus.Configuration.NetEventRelayBindingCollectionElement, Microsoft.ServiceBus, Version=1.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

      </bindingExtensions>

    </extensions>

  </system.serviceModel>

 

  <runtime>

    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">

      <dependentAssembly>

        <assemblyIdentity name="Microsoft.ServiceBus"

                          publicKeyToken="31bf3856ad364e35"

                          culture="neutral" />

        <bindingRedirect oldVersion="1.0.0.0"

                         newVersion="1.6.0.0"/>

      </dependentAssembly>

    </assemblyBinding>

  </runtime>

and it works again.

However, some of the samples did not with 1.6 but only with 1.5. Maybe I messed up with the latest SDK installation.

2 comments:

  1. I just downloaded the sample from http://code.msdn.microsoft.com/windowsazure/Relayed-Messaging-Bindings-2dec7692 and all references are already 1.6.0.0. You may be using the sample from 1.5?

    ReplyDelete
  2. It's really nice blog Its helps you to find error and fix them please go through this site and make good solution of your problem.
    How To Remove Rundll Error
    Thank you
    Aalia lyon

    ReplyDelete